점보 프레임
Jumbo frame컴퓨터 네트워킹에서 점보 프레임은 IEEE 802.3 [1]규격에 의해 설정된 1500바이트 이상의 페이로드를 가진 이더넷프레임입니다일반적으로 점보 프레임은 최대 9000바이트의 payload를 전송할 수 있지만 점점 더 다양한 종류가 존재하기 때문에 이 용어를 사용할 때 주의해야 합니다.다수의 기가비트이더넷 스위치와 기가비트이더넷 네트워크인터페이스 컨트롤러 및 일부 패스트이더넷 스위치와 패스트이더넷 네트워크인터페이스 카드로 점보 [2]프레임을 지원할 수 있습니다.
인셉션
각 이더넷 프레임은 네트워크를 통과할 때 처리되어야 합니다.같은 콘텐츠를 작은 프레임으로 분할하여 처리하는 것보다 하나의 큰 프레임의 콘텐츠를 처리하는 것이 바람직하다.이는 인터럽트를 줄임으로써 사용 가능한 CPU 시간을 보다 효율적으로 활용할 수 있기 때문이다.이것에 의해,[3] 오버헤드바이트의 카운트가 최소한으로 억제되어 처리할 필요가 있는 프레임의 수도 감소합니다.이것은, 1매씩 1매씩의 봉투가 아닌, 종이 패킷을 물리적으로 우송하는 것과 비슷하기 때문에, 봉투가 절약되어 분류 시간을 단축할 수 있습니다.
점보 프레임은 1998년 Alteon Web Systems가 ACEnic 기가비트 이더넷 [4]어댑터에 도입했을 때 처음 눈에 띄었습니다.다른 많은 벤더도 사이즈를 채용하고 있습니다만, 점보 프레임은 공식 IEEE 802.3의 일부가 아닙니다.이더넷 표준
도입
점보 프레임은 오버헤드와 CPU[5] 사이클을 줄이고 엔드 투 엔드 TCP 성능에 [6]긍정적인 영향을 미칠 수 있습니다.점보 프레임의 존재는 네트워크 지연, 특히 저대역폭 링크에 악영향을 미칠 수 있습니다.엔드 투 엔드 접속에서 사용되는 프레임사이즈는 보통 중간 링크의 최소 프레임사이즈에 의해 제한됩니다.802 . 5 토큰 링은 4464바이트의 MTU를 가진 프레임을 지원하며 FDDI는 4352바이트, ATM은 9180바이트, 802.11은 7935바이트의 MTU를 전송할 수 있습니다.IEEE 802.3당초 이더넷 표준에서는 1500바이트의 MTU 프레임, 1518바이트의 합계 프레임사이즈(옵션의 IEEE 802.1Q VLAN/QoS 태그의 경우 1522바이트)에 대한 지원이 의무화되어 있습니다.IEEE 802.3as 업데이트에서는 최대 482바이트의 헤더와 트레일러를 포함할 수 있는 엔벨로프 개념을 생성하여 여러 개의 공통 헤더, 트레일러 및 캡슐화가 적용되었으며 IEEE 802.3에서 지원되는 최대 이더넷프레임이 2000바이트가 되었습니다.
점보 프레임의 우선 페이로드 크기로서 9000 바이트를 사용하는 것은 Internet2의 공동 엔지니어링 팀과 미국 연방 정부 [7]네트워크에서의 논의에서 비롯되었습니다.그들의 권고는 다른 모든 국가 연구 및 교육 네트워크에서 채택되었다.이 필수 구매 기준을 충족하기 위해 제조업체는 9000바이트를 표준 MTU 사이즈로 채택하고 있으며 점보 프레임사이즈는 최소 9018/9022바이트(IEEE 802 미포함/포함)입니다.1Q 필드).[citation needed]대부분의 이더넷 기기는 최대 9216바이트의 [8]점보 프레임을 지원할 수 있습니다.
IEEE 802.1AB-2009 및 IEEE 802.3bc-2009에서는 최대 프레임 길이(TLV 서브타입 4)[9]의 표준 이더넷에 LLDP 검출이 추가되었습니다.2 옥텟필드에 의한 포트에서의 프레임 길이 검출이 가능합니다.IEEE 802.3-2015에서 허용되는 값은 1518(기본 프레임만), 1522(802.1Q 태그 부착 프레임) 및 2000(멀티 태그 부착, 엔벨로프 프레임)[10]입니다.
에러 검출
UDP 및 TCP 트랜스포트 내에 포함된 단순 가산 체크섬은 버스 고유의 비트오류를 검출하는 데 효과적이지 않은 것으로 판명되었습니다.단순 합계에서는 이러한 에러가 자동적으로 취소되는 경향이 있기 때문입니다.RFC 3309를 채택하기 전에 실제 데이터에 대한 에러 주입 시뮬레이션을 사용한 테스트에서는 이들 에러의 2%가 검출되지 않았습니다.
이더넷 프레임에서 사용되는 단순한 CRC32 에러 검출에서는, 큰 프레임에서는 검출되지 않는 에러가 발생할 가능성이 높아집니다.패킷 사이즈가 커지면, 복수의 에러가 서로 [a]상쇄될 가능성이 높아집니다.
점보 프레임을 채택하기 위한 하나의 IETF 접근방식은 이더넷 위의 다음 네트워크 프로토콜 계층에서 추가 CRC를 실행함으로써 서비스 데이터 유닛의 데이터 무결성 저하를 방지합니다.Stream Control Transmission Protocol(SCTP) 전송(RFC 4960) 및 iSCSI(RFC 7143)는 Castagnoli CRC 다항식을 사용합니다.Castagnoli 다항식 0x1EDC6F41은 1개의 이더넷 MTU(16,360비트 데이터 워드 길이까지)를 초과하는 Hamming 거리 HD=6 및 HD=4 ~ 114,663비트를 달성합니다.이는 MTU 크기의 표준 이더넷 워드와 비교하여 2비트의 오류 검출 능력을 제공합니다.최대 72kbit [12]이상의 데이터 워드 크기를 위해 HD=4 기능을 희생하지 않습니다.데이터 청크를 처리하도록 설계된 범용 트랜스포트 내에서 Castagnoli CRC 다항식을 지원하며 SCSI 데이터를 전송하도록 설계된 TCP 트랜스포트 내에서 둘 다 점보 프레임을 사용하더라도 오류 검출률이 향상됩니다.점보 프레임이 사용되지 않으면 오류 검출이 대폭 감소합니다..
배열
일부 벤더는 최대 프레임사이즈(프레임헤더, 레이어2 패킷사이즈 포함) 또는 최대 전송 유닛(프레임헤더를 제외한 레이어3 패킷사이즈) 중 하나를 사이즈 설정에 포함시키고 있지 않은 벤더도 있습니다.따라서 설정을 [citation needed]일치시키려면 다른 벤더의 기기에 다른 값을 설정해야 할 수 있습니다.
점보 프레임용으로 설정된 디바이스와 네트워크에서 점보 프레임용으로 구성되지 않은 디바이스가 혼재하면 네트워크 성능 [13]문제가 발생할 수 있습니다.
대역폭 효율
점보 프레임은, 다음의 TCP over IPv4 의 예에 나타내듯이, 프로토콜의 오버헤드를 줄여, 호스트의 이더넷 및 네트워크 처리의 효율을 높일 수 있습니다.호스트의 처리 오버헤드는 페이로드 크기의 비율만큼 감소할 수 있습니다(이 예에서는 약 6배 향상).이것이 중요한지 여부는 호스트에서 패킷이 처리되는 방식에 따라 달라집니다.TCP 오프로드 엔진을 사용하는 호스트는 CPU로 프레임을 처리하는 호스트보다 이점이 적습니다.
| 프레임 타입 | MTU | 레이어 1 오버헤드 | 레이어 2 오버헤드 | 레이어 3 오버헤드 | 레이어 4 오버헤드 | 페이로드 크기 | 송신[A] 총수 | 효율[B] | |||
|---|---|---|---|---|---|---|---|---|---|---|---|
| 표준. | 1500 | 프리암블 8 바이트 | IPG 12 바이트 | 프레임 헤더 14 바이트 | FCS 4 바이트 | IPv4 헤더 20 바이트 | TCP 헤더 20 바이트 | 1460 바이트 | 1538 바이트 | 94.93% | |
| 점보 | 9000 | 프리암블 8 바이트 | IPG 12 바이트 | 프레임 헤더 14 바이트 | FCS 4 바이트 | IPv4 헤더 20 바이트 | TCP 헤더 20 바이트 | 8960 바이트 | 9038 바이트 | 99.14% | |
| 기타 참조용 프레임 크기 | |||||||||||
| IEEE 802.11[14][15] | 7935 | PLCP 프리암블 및 헤더 24 바이트 | IPG 다르다 | 프레임 헤더 및 보안 ovhd 52 바이트 | FCS 4 바이트 | IPv4 헤더 20 바이트 | TCP 헤더 20 바이트 | 7895 바이트 | 8015 바이트 + IPG 사이즈 | 98.5% 미만 | |
| IEEE 802.11을 이더넷에 브리지 | 1500 | PLCP 프리암블 및 헤더 24 바이트 | IPG 다르다 | 프레임 헤더 및 보안 ovhd 52 바이트 | FCS 4 바이트 | IPv4 헤더 20 바이트 | TCP 헤더 20 바이트 | 1460 바이트 | 1580 바이트 + IPG 사이즈 | 92.4% 미만 | |
패킷 전송 레이트의 함수로서의 네트워크 데이터 throughput의 상대적 scalability는 패킷당 [16]payload 크기와 복잡한 방식으로 관련되어 있습니다.일반적으로 라인 비트환율이 증가함에 따라 패킷페이로드 사이즈는 동등한 타이밍 파라미터를 유지하기 위해 직접 비례하여 증가해야 합니다.단, 이는 네트워크 경로를 따라 다수의 중간 논리회로를 확장하여 필요한 최대 프레임사이즈에 대응할 수 있음을 의미합니다.
베이비 자이언트 프레임
베이비 자이언트 또는 베이비 점보 프레임은 IEEE 이더넷 [2]표준에서 허용된 것보다 약간 큰 이더넷프레임입니다예를 들어 베이비 자이언트프레임은 IP/MPLS over Ethernet이 표준 1500바이트 페이로드의 이더넷서비스를 제공하기 위해 필요합니다.대부분의 구현에서는 비점보 사용자 프레임을 MPLS 프레임 형식으로 캡슐화해야 합니다.이러한 프레임은 EtherType 값이 0x8847 및 [17]0x8848인 적절한 이더넷프레임 형식으로 캡슐화 될 수 있습니다.추가 MPLS 및 이더넷헤더의 오버헤드가 증가하면 캐리어 이더넷네트워크에서는 [18]최대 1600바이트의 프레임 지원이 필요합니다.
슈퍼 점보 프레임
Super Jumbo Frame(SJF; 슈퍼점보 프레임)은 페이로드 크기가 9000바이트를 넘는 프레임입니다.하이 퍼포먼스 국가 연구 및 교육 네트워크의 패스 MTU를 1500바이트에서9000바이트 정도로 늘리는 것은 비교적 어렵고 다소 시간이 걸리는 프로세스이기 때문에 64,000바이트로 늘리는 것이 검토되고 있습니다.관련된 주요 요인은 경로를 따라 개입하는 모든 지속성 메커니즘에서 사용 가능한 메모리 버퍼 크기가 증가하는 것입니다.고려해야 할 또 하나의 중요한 요인은 더 큰 프레임 크기 내에서 오류를 검출할 때 CRC32의 효율성이 더욱 떨어진다는 것입니다.
대체 어프로치
프레임당 대용량 송신 오프로드 및 대용량 수신 오프로드 처리로 프레임 크기에 크게 의존하지 않는 CPU 부하이는 점보 프레임이 [19]감소하도록 설계된 패킷 단위의 오버헤드를 제거하는 또 다른 방법입니다.점보 프레임은 비데이터 오버헤드에 사용되는 대역폭을 줄이기 때문에 대역폭 관점에서 여전히 유용합니다.
「 」를 참조해 주세요.
- 점보그램, IPv6 용 대용량 패킷
메모들
레퍼런스
- ^ "Ethernet Jumbo Frames" (PDF). Ethernet Alliance. 2009-11-12. Retrieved 2015-06-18.
- ^ a b "Jumbo/Giant Frame Support on Catalyst Switches Configuration Example". Cisco. Retrieved 2011-08-22.
Catalyst 3750/3560 Series switches support an MTU of 1998 bytes for all 10/100 interfaces
- ^ "Ethernet Jumbo Frames" (PDF). EthernetAlliance.org. Retrieved April 28, 2017.
- ^ Jeff Caruso (October 22, 1998). "Alteon still stumping for Jumbo Frames". Network World. Archived from the original on 2012-10-15. Retrieved July 4, 2011.
- ^ Foong, A; T. Huff; H. Hum; J. Patwardhan; G. Regnier (2003). "TCP Performance Re-visited". 2003 IEEE International Symposium on Performance Analysis of Systems and Software. ISPASS 2003. pp. 70–79. doi:10.1109/ISPASS.2003.1190234. ISBN 978-0-7803-7756-1. S2CID 17023487.
- ^ D Murray; T Koziniec; K Lee; M Dixon (2012). "Large MTUs and internet performance". 2012 IEEE 13th International Conference on High Performance Switching and Routing. pp. 82–87. doi:10.1109/HPSR.2012.6260832. ISBN 978-1-4577-0833-6. S2CID 232321.
- ^ Rick Summerhill (17 Feb 2003), rrsum-almes-mtu, Internet2
- ^ Scott Hogg (2013-03-06), Jumbo Frames, Network World, retrieved 2013-08-05,
Most network devices support a jumbo frame size of 9216 bytes.
- ^ IEEE 802.3 79.3.4 최대 프레임사이즈 TLV
- ^ IEEE 802.3 3.2.7 MAC Client Data 필드
- ^ Mathis, Matt (2016-10-08). "Arguments about Internet MTU". Archived from the original on 2016-10-08. Retrieved 2019-08-23.
- ^ Philip Koopman. "32-Bit Cyclic Redundancy Codes for Internet Applications" (PDF). ECE Department & ICES, Carnegie Mellon University.
- ^ "Guidance on the use of jumbo frames". Netgear. Retrieved 2020-03-21.
- ^ Philip (October 20, 2016). "Wireless Network Speed Tweaks". speedguide.net. Retrieved October 20, 2016.
- ^ IEEE 802.11-2012 8.2.3 일반 프레임 형식
- ^ Rutherford, W.; Jorgenson, L.; Siegert, M.; Van Epp, P.; Liu, L. (2007). "16000–64000 B pMTU experiments with simulation: The case for super jumbo frames at Supercomputing '05". Optical Switching and Networking. 4 (2): 121–130. doi:10.1016/j.osn.2006.10.001.
- ^ RFC-3032, MPLS 라벨 스택 부호화
- ^ Ceragon, 점보 프레임: 마이크로파 관점, 기술 개요 2012-09-15년 Wayback Machine에 보관
- ^ "Coding Relic: Requiem for Jumbo Frames". 2011-12-07. Retrieved 2011-12-07.
외부 링크
- 점보 프레임– 사용처
- 점보 프레임? Yes! by Selina Lo, Alteon Networks, 1998년 2월 23일 Network World
- 인터넷 MTU 푸시업
- IEEE 802.3as 프레임 확장 태스크포스
- 인터넷 응용 프로그램용 32비트 순회 용장성 코드
- 알아야 할 사항:소규모 네트워크에서의 점보 프레임
- Arch Linux Wiki 점보 프레임