인터랙티브 접속 확립
Interactive Connectivity EstablishmentInteractive Connectivity Establishment(ICE; 인터랙티브 연결 확립)는 피어 투 피어 네트워킹에서 두 컴퓨터가 서로 가능한 한 직접 통신할 수 있는 방법을 찾기 위해 컴퓨터 네트워킹에서 사용되는 기술입니다.이것은 Voice over Internet Protocol(VoIP), 피어 투 피어 통신, 비디오, 인스턴트 메시징 등의 대화형 미디어에 가장 일반적으로 사용됩니다.이러한 애플리케이션에서는 중앙 서버를 통한 통신은 느리고 비용이 많이 들지만 Network Address Translator(NAT; 네트워크주소 변환기), 방화벽 및 기타 네트워크 장벽 때문에 인터넷상의 클라이언트애플리케이션 간의 직접 통신은 매우 어렵습니다.
ICE는 Internet Engineering Task Force MMUSIC 워킹그룹에 의해 개발되어 2018년 [1]8월 현재 RFC 8445로 발행되고 있으며 RFC 5245와[2] RFC 4091 [3]모두 폐지되었습니다.
개요
Network Address Translation(NAT; 네트워크주소 변환)은 본질적으로 약 40억 개의 고유 주소로 제한되는 Internet Protocol 버전4의 사용 가능한 주소 풀의 고갈을 지연시키는 효과적인 기술이 되었습니다.NAT 게이트웨이는 프라이빗네트워크로부터의 발신 요구를 추적하여 확립된 각 접속 상태를 유지하고 퍼블릭네트워크상의 피어에서 프라이빗네트워크내의 피어에의 직접 응답에 대해서 나중에 직접 행선지를 지정할 수 없게 됩니다.
VoIP, 피어 투 피어 및 기타 많은 응용 프로그램은 인터넷 프로토콜 패킷헤더뿐만 아니라 접속 데이터 스트림 내에서 통신하는 피어의 주소 정보를 필요로 합니다.예를 들어 Session Initiation Protocol(SIP)은 로케이션서비스에 등록하기 위한 네트워크 클라이언트의 IP 주소를 통신하여 전화 콜을 등록된 클라이언트에 라우팅합니다.ICE 는, 다른 피어(peer)가 도달할 수 있도록, 통신 피어가 퍼블릭 IP 주소를 검출해 통신할 수 있는 프레임워크를 제공합니다.
STUN(Session Traversal Utilities for NAT)은 NAT 분류를 포함하여 이러한 주소 검색을 위한 표준화된 프로토콜입니다.Traversal Using NAT(TRUNG)은 피어 간의 직접 미디어 트래픽이 방화벽에 의해 허용되지 않는 경우 서드파티 서버를 배치하여 2개의 클라이언트 간에 메시지를 릴레이합니다.
IETF 사양
- RFC 5389: NAT용 세션트래버설 유틸리티(STUN)
- RFC 8656: 릴레이를 사용한 NAT 주변 통과(TRUNG): 릴레이 확장을 STUN으로
- RFC 6544: Interactive Connectivity Establishment(ICE; 대화식 연결 확립)를 사용한TCP 후보
- RFC 8445: Interactive Connectivity Establishment(ICE; 인터랙티브 연결 확립): Network Address Translator(NAT; 네트워크주소 변환기) 트래버설용 프로토콜
「 」를 참조해 주세요.
- Realm-Specific IP(RSIP; 영역 고유 IP)
- 미들박스(Middlebox Communications 또는 MIDCOM)
- 유니버설 플러그 앤 플레이(UPnP)
- NAT Port Mapping Protocol(NAT-PMP)
- Port Control Protocol(PCP)
레퍼런스
- ^ RFC 8445 "Interactive Connectivity Establishment(ICE)" : Network Address Translator(NAT) Traversal 프로토콜, A. Keranen, C.Holmberg Ericson, J. Rosenberg (2018년 7월)
- ^ RFC 5245, Interactive Connectivity Establishment(ICE; 인터랙티브 연결 확립): 제안/응답 프로토콜을 위한 NAT(Network Address Translator) 트래버설 프로토콜, J. Rosenberg (2010년 4월)
- ^ RFC 4091, SDP 그룹화 프레임워크의 대체 네트워크 주소 유형(ANAT) 의미론, G. Camarillo, J. Rosenberg (2005년 6월)